Vai al contenuto
jakeron

Problema fps utilizzando FRAPS

    Post Raccomandati

    Stavo provando a registrare un colpo in GTA5 ieri, ma appena faccio partire la registrazione con fraps ho un calo di frame mostruoso (passo dai 60/65 ai 22/25 e anche meno, diventa praticamente ingiocabile).. ho letto qua però che molti di voi usano fraps e non hanno nessun problema di frame, cosa mi consigliate?

     

    Ps. gioco a 1440p, potrebbe essere quello il problema? nel senso che registrare ad una risoluzione così alta mi fa avere quel calo di frame?

     

    Edit: ho appena provato a portare la risoluzione a 1080p, ma come prima passa da 76/80 fps a 35 (con tantissimi cali), quindi il problema non dovrebbe essere la risoluzione

    Modificato il da jakeron

    Condividi questo messaggio


    Link di questo messaggio
    Condividi su altri siti

    Ho spostato qui la discussione ;)

     

    I driver della tua r9 280 sono aggiornati all'ultima versione? Se si, prova con una versione precedente, ovviamente dopo aver disinstallato i driver con DDUninstaller ;)

    Condividi questo messaggio


    Link di questo messaggio
    Condividi su altri siti

    In realtà i driver non sono aggiornati all'ultima versione.. Ora sto provando ad aggiornarli per vedere se cambia qualcosa (ho disinstallato quelli vecchi con DDUninstaller)

    Condividi questo messaggio


    Link di questo messaggio
    Condividi su altri siti

    In realtà i driver non sono aggiornati all'ultima versione.. Ora sto provando ad aggiornarli per vedere se cambia qualcosa (ho disinstallato quelli vecchi con DDUninstaller)

    Hai provato a dare un occhio alle impostazioni di fraps? In particolare alla sezione riguardante gli fps appunto.

    Facci sapere.

     

    Inviato dal mio GT-I9515 utilizzando Tapatalk

    Condividi questo messaggio


    Link di questo messaggio
    Condividi su altri siti

    Ho provato con tutte le impostazione di fraps, cambiando gli FPS a cui registrare il video la situazione è la stessa, invece selezionando la casella "half-size" al posto di "full-size" la situazione migliora leggermente (dai 20 fps ci si sposta sui 40, ma con moltissimi lag) durante il gioco ma quando vado a riguardare il video che ho registrato si vede una gran bella schermata nera e basta.. Domani provo a reinstallare fraps, se non dovesse funzionare nemmeno così proverò con qualche altro programma

    Condividi questo messaggio


    Link di questo messaggio
    Condividi su altri siti

    Ho provato con tutte le impostazione di fraps, cambiando gli FPS a cui registrare il video la situazione è la stessa, invece selezionando la casella "half-size" al posto di "full-size" la situazione migliora leggermente (dai 20 fps ci si sposta sui 40, ma con moltissimi lag) durante il gioco ma quando vado a riguardare il video che ho registrato si vede una gran bella schermata nera e basta.. Domani provo a reinstallare fraps, se non dovesse funzionare nemmeno così proverò con qualche altro programma

     

    Hai  provato ad attivare il vsync mentre giocavi? Ti da lo stesso problema?

     

    Prova ad attivare il vsync e dalle impostazioni di fraps ,con vsync attivo nel gioco, metti :

     

    full size (sarebbe registrazione in full hd)

    fps del file di output : 30 (ma prova anche 60 eh , provali entrambi sempre con vsync attivo)

     

    Il gioco tienilo a 1920x1080 di risoluzione per ora.

     

    E vedi come va.

     

    Altra domanda (importante dato che ci sono passato anche io) : l' hdd dove vengono registrati i file di output di fraps è il caviar blue da 7200 rpm che vedo in descrizione giusto? O è un altro più lento che li non vedo?

    Condividi questo messaggio


    Link di questo messaggio
    Condividi su altri siti

    Con il vsync non ho provato, ho attivato con il monitor il freesync di AMD, ma non so se con quello cambia qualcosa. Stasera provo a tenerli entrambi attivi e anche ad attivare solo il vsync per vedere come va (provando registrazione in 1080p a 30 e 60 fps).

     

    Per quanto riguarda l'hark disk purtroppo ho sbagliato ad acquistarlo (l'avevo scritto un paio di mesi fa nella discussione dove mi avete consigliato la configurazione, me ne sono accordo dopo ben 1 anno ahaha), quindi ho un purple da 5400 rpm. Potrebbe essere che non riesce a scrivere le cose che registra abbastanza velocemente?

    (Sorry non ho mai aggiornato la lista dei miei componenti dopo averlo scoperto)

    Condividi questo messaggio


    Link di questo messaggio
    Condividi su altri siti

    Con il vsync non ho provato, ho attivato con il monitor il freesync di AMD, ma non so se con quello cambia qualcosa. Stasera provo a tenerli entrambi attivi e anche ad attivare solo il vsync per vedere come va (provando registrazione in 1080p a 30 e 60 fps).

     

    Ok fai prove e varie combinazioni di questi settaggi e fammi sapere ma.....

     

     

    Per quanto riguarda l'hark disk purtroppo ho sbagliato ad acquistarlo (l'avevo scritto un paio di mesi fa nella discussione dove mi avete consigliato la configurazione, me ne sono accordo dopo ben 1 anno ahaha), quindi ho un purple da 5400 rpm. Potrebbe essere che non riesce a scrivere le cose che registra abbastanza velocemente?

    (Sorry non ho mai aggiornato la lista dei miei componenti dopo averlo scoperto)

     

    .....ma ecco il possibile (ma non sicuro) problema :P  , quindi rispondendo alla tua domanda in neretto : si , potrebbe essere eccome che sia l' hdd che non riesce a scrivere i file in maniera abbastanza veloce e quindi fa da "collo di bottiglia" all' intera registrazione e quindi alle performance del gioco ^^ , potrebbe essere eccome.

     

    Come vedi te l'ho chieso subito perchè ci sono passato anche io in passato proprio con il mio caviar green da 5400 rpm , avevo problemi simili in molti giochi (non lo faceva in tutti) ma poi passando ad un hdd più veloce (al momento registro sul caviar black) i problemi sono magicamente risolti come per magia ;)

     

    Poi sia chiaro che a volte l' hdd non c'entra nulla e tali problemi si possono verificare comunque ma appunto si risolvono agevolmente smanettando con impostazioni di fraps in primis e/o con quelle del gioco.

     

    Di base prova col vsync attivo ma non andare oltre i 30 fps di registrazione nel file di output di fraps e magari metti half size di registrazione , cosi facendo il file di output sarà meno pesante per ovvi motivi (maggiori sono gli fps più pesante è il file , idem per la risoluzione di registrazione ..... più pesante è il file e più l'hdd deve scrivere una maggiore quantità di roba ed essendo lento nel farlo si hanno cali di prestazioni ;) )

     

    Comunque fai lo stesso le prove sopra citate e vedi come va. Peccato che hai una vga amd , con nvidia avresti avuto shadowplay che registra in maniera più leggera (lo è anche il file di output) ergo forse (non è sicuro) tali problemi sarebbe stati meno evidenti ecco.

     

    Altro programma di registrazione che potresti provare anche è dxtory ^^

    Condividi questo messaggio


    Link di questo messaggio
    Condividi su altri siti

    All'hdd non avevo proprio pensato sinceramente..

    Proverò a mettere tutte le impostazioni che mi hai detto sia in fraps che in GTA e magari provo anche a registrare qualcosa di più leggero per vedere come si comporta. Se anche così non dovesse funzionare provo a registrare con dxtory per vedere se va meglio.

     

    Se non dovessi riuscire nemmeno in questi modi butto via la mia r9 280 e il caviar purple e mi prendo una 980ti ed un caviar Black ahahahaha

    ( A parte gli scherzi sono molto fiero della mia VGA, va veramente bene :D )

    Condividi questo messaggio


    Link di questo messaggio
    Condividi su altri siti

    Crea un account o accedi per lasciare un commento

    Devi essere un membro per lasciare un commento

    Crea un account

    Iscriviti per un nuovo account nella nostra comunità. È facile!

    Registra un nuovo account

    Accedi

    Sei già registrato? Accedi qui.

    Accedi Ora


    • Risposte

      • Intendi questo ?? CPU: Intel i5 4690K
        - RAM: 16 GB DDR3
        - SK. VIDEO: ASUS R9 280X con 3GB
        - SK. MADRE: Asrock Z97 Extreme 6
        - ALIM: Cooler Master 550W
        - Cabinet
        450 euro  (completo)   Poi però mi avevo consigliato questo, per miglior rapporto prezzo/prestazioni: - Intel Core i5 3470 @3,2 GHz con dissipatore ARCTIC Freezer 7 Pro Rev. 2
        - 8 (2x4) GB RAM DDR3 1600 Mhz (Corsair Vengeance LP)
        - Sapphire HD 7850 2GB
        - PSU: XFX 550W Bronze
        - HDD: Seagate Barracuda 1TB 7200 RPM
        - MOBO: ASRock Z77 Pro3
        - Case Thermaltake Commander MS-I Snow Ed.
        280 euro  (completo)
      • Ciao, mi chiamo Andrea, mi sono appena iscritta, amo viaggiare (quando posso 😄), pratico diversi sport, una volta a livello agonistico, guidare auto in pista, solo per passione e giochi per lo più di guida tipo need for speed, quasi tutti, forza motor sport , forza horizon, redident evil,  skyrim, e molti altri.  
      • Grazie per la risposta. Oggi ho un po' smanettato e, sforando un po' il budget avevo "creato" questa configurazione Ram: (ho cambiato e messo quella consigliata da te) HyperX Predator 8GB 3000MHz DDR4 8GB DDR4 3000MHz memoria https://www.amazon.it/dp/B071ZZCSQZ/ref=cm_sw_r_cp_apa_RQ72AbRE8J8TP Alimentatore: (lo stesso che mi hai raccomandato te) https://www.amazon.it/dp/B019NWTCEA/ref=cm_sw_r_cp_awdb_c_i172AbJBR482V Scheda madre: https://www.amazon.it/dp/B01MR248SI/ref=cm_sw_r_cp_awdb_c_I372AbVMP6R7V Scheda video: https://www.amazon.it/dp/B078ZT22SS/ref=cm_sw_r_cp_awdb_c_C472AbF46PH5Z Processore: https://www.amazon.it/dp/B0759FGJ3Q/ref=cm_sw_r_cp_awdb_c_x572AbEN5VVJ4 Case: https://www.amazon.it/dp/B0778YCB7C/ref=cm_sw_r_cp_awdb_c_D672AbXQN24P4 Secondo te questa va bene? Piu che altro quei 100€ in più che vado a spendere mi garantiscono più longevità (perché a livello di prestazioni mi bastava anche la tua configurazione). Per l'hdd ho pensato di usarne uno vecchio da 1 tera che avevo su un portatile e che ho fatto inscatolare per  usarlo come disco esterno, solo che non so se va bene su un pc fisso, visto che era su un portatile (non ho modo di vedere il modello sennò te lo linkerei) comunque lo userei come disco secondario quindi anche se è meno performante non mi interessa molto. Fammi un po' sapere che ne pensi e grazie ancora per la tua disponibilità.  P. S. Di pezzi non ne servono mica altri vero?
    ×